Honda 599 Forum

Go Back   Honda 599 Forum > General Community > Accessories and Modifications

Accessories and Modifications Ah the fun of enhancing your motorcycle. Here you will find retailers and advice.

Reply
 
Thread Tools Display Modes
Old 11-30-2018, 02:11 PM   #1
nitroheadz28
Junior Member
 
Join Date: Sep 2016
Posts: 16
Default Issues with Clear Alternatives LED tail light

*FIXED*



Hey guys, I purchased my 599 with this tail light 2.5 years ago and not long after people riding with me would tell me it would flicker going over bumps.


Fast forward to a few days ago and the running light stopped working completely. I tapped on the tail light a few times and it would come on here & there but eventually stopped. The brake light and turn signals function as they should.



I took everything apart today expecting to find a loose connection and everything looks fine, circuit board on the light seems fine.



The wiring diagram in the manual hasn't been much help so far (Doesn't help that I suck at electrical past checking for voltage and resistance).


I'm assuming the two green/ yellow are for the turn signal. Still trying to work off the manual so I can go through this properly.


Anyone had this issue or can help diagnose? Thanks in advance

Last edited by nitroheadz28; 11-30-2018 at 04:07 PM.
nitroheadz28 is offline   Reply With Quote

Old 11-30-2018, 04:13 PM   #2
nitroheadz28
Junior Member
 
Join Date: Sep 2016
Posts: 16
Default Re: Issues with Clear Alternatives LED tail light

Okay so a little more detective work got me the culprit which is what I thought it was the whole time.


Whoever installed this tail light did such a pretty horrible job. In case anyone has the same issue going forward..


I checked voltage along the connections and noticed the light was getting power for the continuous light and obviously the other wire was getting power when I tapped the brakes.


Fiddling around tugging at the wires I discovered that the red wire (Continuous) which was soldered on and hot glued to the circuit board had a poor connection. The green wire is for the brake lights and just ground after that.


At least it was an excuse to take off my DIY fender eliminator and license plate bracket to paint
nitroheadz28 is offline   Reply With Quote
Old 11-30-2018, 06:03 PM   #3
Joelittel
Senior Member
 
Join Date: May 2013
Posts: 183
Default Re: Issues with Clear Alternatives LED tail light

Glad it all worked out well for you.

Post some pictures of your fender eliminator, I’d love to see it.
Joelittel is offline   Reply With Quote
Old 12-02-2018, 08:05 AM   #4
ljtenkor
Junior Member
 
Join Date: Jun 2018
Posts: 1
Default Re: Issues with Clear Alternatives LED tail light

I bought a 599 about 6 months ago with the same taillight and within a month the light stopped working. I could get it to light up when I loosened it and moved it around, so I first checked the connections. Turned out that the leads from the light had been poorly soldered. I re-did the connections and its been problem-free since.
ljtenkor is offline   Reply With Quote
Old 12-04-2018, 05:40 PM   #5
nitroheadz28
Junior Member
 
Join Date: Sep 2016
Posts: 16
Default Re: Issues with Clear Alternatives LED tail light

Quote:
Originally Posted by Joelittel View Post
Glad it all worked out well for you.

Post some pictures of your fender eliminator, Id love to see it.

I made a quick write up for ya:


http://www.honda599.com/forums/showt...894#post256894
nitroheadz28 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.